Computer/Algorithm

Daily Algorithm - 스택

kentakang 2018. 5. 29. 00:27
반응형

문제

정수를 저장하는 스택을 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 다섯 가지이다.

  • push X: 정수 X를 스택에 넣는 연산이다.
  • pop: 스택에서 가장 위에 있는 정수를 빼고, 그 수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • size: 스택에 들어있는 정수의 개수를 출력한다.
  • empty: 스택이 비어있으면 1, 아니면 0을 출력한다.
  • top: 스택의 가장 위에 있는 정수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.

입력

첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 
둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 
주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.

출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

예제 입력

14 push 1 push 2 top size empty pop pop pop size empty pop push 3 empty top

예제 출력

2
2
0
2
1
-1
0
1
-1
0
3

풀이

package boj10828;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
private int top = -1;
private int[] stack = new int[10000];

public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
Main stack = new Main();
int n = Integer.parseInt(br.readLine());

for (int i = 0; i < n; i++) {
String command = br.readLine();

if (command.contains("push")) {
int num = Integer.parseInt(command.substring(5));
stack.push(num);
} else {
switch (command) {
case "pop":
System.out.println(stack.pop());
break;
case "size":
System.out.println(stack.size());
break;
case "empty":
System.out.println(stack.empty());
break;
case "top":
System.out.println(stack.top());
break;
}
}
}
}

void push(int n) {
stack[++top] = n;
}

int pop() {
if (top == -1)
return -1;
else
return stack[top--];
}

int size() {
return top + 1;
}

int empty() {
if (top == -1)
return 1;
else
return 0;
}

int top() {
if (top == -1)
return -1;

return stack[top];
}
}

스택 자체는 이미 다뤄본 적이 있는 자료구조라 쉽게 구현할 수 있었다.

오히려 명령어를 처리하는 부분이 더 번거로운 것 같다.


문제 출처 : https://www.acmicpc.net/problem/10828


반응형